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Course Objectives 

This course consists of 6 lessons, and each lesson has one primary objective: 

1. Workspace Overview 

2. Setting preferences and personalizing workspace 

3. Exploring and Managing Items 

4. Importing Artifacts 

5. SmartView 

6. Administration Module 
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Lesson 1: Workspace Overview 

About Workspace 

Workspace is a DHTML-based, zero-footprint client that provides the user interface for 
viewing and interacting with content created using Hyperion® System™ 9 BI+™ 
authoring studios and financial applications: 

 Enterprise metrics for management metrics and analysis presented in easy-to-
use, personalized, interactive dynamic dashboards. 

 Financial reporting for scheduled or on-demand highly formatted financial and 
operational reporting from most data sources including Hyperion® System™ 9 
Planning™ and Hyperion® System™ 9 Financial Management™. 

 Interactive reporting for ad hoc relational queries, self-service reporting, and 
dashboards against ODBC data sources. 

 Production reporting for high volume enterprise-wide reporting  

 Web analysis for interactive ad hoc analysis, presentation, and reporting of 
multidimensional data. 

 High performance multidimensional modeling, analysis, and reporting with 
Hyperion® System™ 9 BI+™ Analytic Services™ BI+, which includes Analytic 
Services, is part of a comprehensive BPM system that integrates the business 
intelligence platform with financial applications, Hyperion® System™ 9 Smart 
View for Office™, and Hyperion® System™ 9 Performance Scorecard™. 

 

Accessing Workspace  

To access workspace follow the instructions below: 

1. From your browser, type the following URL: 

 http://localhost:19000/workspace/index.jsp 

2. At the login screen, type in Username:admin and Password:password.  Click Log 
On. 

 

Review Lesson 1 Objectives 

Congratulations, you’ve completed the Workspace Overview lesson. 
 
You’re now able to perform the following tasks: 
 

1. Workspace Overview 

2. Log on to Workspace. 
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Lesson 2: Demonstrate How to Set Preferences 
& Personalize Workspace 

Lesson 2 Overview 

Set defaults for general appearances of the user interface, Explore, authentication, 
applications, file types and Studios.  

 

Setting Preferences 

Set defaults for general appearances of the user interface, Explore, file types and 
Studios. Use these preferences tabs: 

●―Setting General Preferences‖ 

●―Setting Explore Preferences‖  

●―About Module Preferences‖  

User interface settings made with the View menu override default settings defined from 
General Preferences and stay until logging off. When you log on, user interface settings 
from Preferences are used. Set General tab preferences to hide the Masthead; display 
the Masthead: View > Masthead. User interface settings made with the View menu 
override settings made with preferences until you logoff. 

Setting preferences saves time from doing it every time dialogs or Web pages are 
displayed. 

Setting General Preferences 

General preferences set defaults for the Masthead, View Pane, UI appearance, and 
default start page for the Content area. Change passwords after logging on to the 
Workspace. This option is available to users with native authentication parameters 
specified, not external authentication. 

Changes made using Preferences go into effect next time you log on. 

General preferences: 

1. File > Preferences. 

2. Deselect options you do not want displayed. 

Note: The e-mail address displayed is your e-mail address registered in your 
user’s security settings. You cannot update it. 

3. Hide document file paths in the progress bar by clearing Show Paths for 
Documents. 

4. Workspace prompts you to save unsaved files by checking Prompt to Save 
Unsaved Files. 

5. The Default Startup Options for the View Pane Tab are: 
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o Document, if users have the Explorer role. 

o Navigate, if users do not have the Explorer role. 

Note: If the default content does not have a Document tab and the default is 
set to Document, the View Pane Tab defaults to Tips. 

6. In Default Startup Options for Content, select an option to display by default 
whenever you log in to Workspace. The default option is Explorer, if users have 
the Explorer role and None if not. 

7. Depending on your selection in step 6, complete the following:  

o Desktop option, click Use Current Page to select a page you have 
open to display in the Content area. 

o Explore option, click Select. From Select, select a folder and click 
Ok. The path and folder displays in Folder. 

o Document option, select Select. From Select, select a document 
and click Ok. The path and document name displays in the 
Document text box. 

o Favorite option, select one of the following: 

o Click Use Current Page to select a page you have open to 
display in the content area. 

o Select a page from Favorite. The page displays in Favorite. 

o Enterprise Metrics option, click Use Current Page to select a page 
you have open to display in the content area. 

o Scorecard option, select one of the following: 

o Click Use Current Page to select a page you have open to 
display in the content area. 

o Enter a Scorecard/Map name in the text box. 

8. Perform one of the following tasks: 

o Save changes, click OK. 

o Cancel changes, click Cancel. 

 

Setting Authentication Preferences 

Set Authentication preferences to change your Workspace login password. 

 

Set Authentication preferences: 

1. File > Preferences, click Authentication. 

2. In Change Password, enter your current password and a new password. 

3. Re-enter your new password. 
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4. Click OK. 

For Interactive Reporting and Production Reporting authentication: 

1. File > Preferences, click Authentication. 

2. Repeat steps step 2 through step 4 above in the In Credentials Used for Pass-
Through area.  

Setting Explore Preferences 

Set Explore preferences to define default folders and default permissions for items that 
you create or import. You can specify default permissions for specific users, groups or 
roles. If you do not set these preferences, the Default folder, Desktop folder, and New 
Document folder are set to the top-most or root folder and permissions for items are set 
to Empty. 

You can modify the following Explorer Preferences: 

 Default Folder - Your default folder is shown when you use Explore. Set it to the 
folder you access most frequently. 

 New Document Folder -The New document folder is the default folder where the 
new document wizard searches for Web Analysis database connection files and 
Interactive Reporting documents. If you are creating new Interactive Reporting 
documents and browse for data sources this folder is used. 

 Default File Permissions - Default file permissions are applied when you create or 
import items. Default file permissions determine: 

o The ability of a user, group, or role to access the item. 

o Whether to automatically push the item to the user, group, or role favorites. 

Note: These default file permissions are automatically applied to all items 
you create or import. You can override these defaults by manually 
changing the permissions when you create or import the item. 

Set default folders: 

1. File > Preferences, click the Explore tab. 

2. Set the Default folder, Desktop folder and New Document folder. 

3. Click Select, and do one of the following steps: 

 From Look in, select a folder. 

 From the list of names: 

o Select a folder 

o To navigate, double-click a folder 

 The folder you select is displayed in the Name text box. 

 Tip: Do not type a name in the Name text box. 

4. From Default File Permissions, select one of the following: 

 Interactive Reporting documents 
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 Interactive Reporting jobs 

 Production Reporting jobs 

 Generic jobs 

 All other documents 

5. Click OK or Cancel 

6. To continue setting default permissions, repeat step 3. 

Set default file permissions: 

1. Select Set Permissions to set default permissions for users, groups, and roles. 
The Permissions dialog is displayed.  
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Lesson 3: Explore & Manage Items 

Lesson 3 Overview 

This lesson explains how to explore and manage items in workspace.  At the end of this 
lesson you should have an understanding of the following: 

 Workspace and user credentials 

 Basics of Explore 

 Viewing Priorities exceptions and versions 

 Managing files  

 Creating and managing folders 

 Searching for files and folders 

 Creating e-mail links 

 Registering File Types 

 

Workspace and User Credentials: 

 Workspace installs Enterprise Metrics, Web Analysis, Interactive Reporting, 
Financial Reporting, Production Reporting, and Performance Scorecard. 
Available features are determined by the modules installed. Web Analysis must 
be installed to view Web Analysis documents.  

 Access privileges or permissions determine which items you can view, modify, 
run and delete in the repository. 

 Roles determine toolbars, menu bars, shortcut menus, and modules displayed on 
the user interface and tasks you can perform. If your role enables you to create 
documents, the toolbar menu item that creates documents (File > New > 
Document) is displayed. 

 Procedures describe how to perform tasks using the menu bar; tasks can also be 
performed using the toolbar and shortcut menus. 
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Basics of Explore 

Use Explore to list, find or view content. Items opened in Explore display as tabs at the 
bottom of the Workspace. The View pane displays folders. When Explore is active, the 
following buttons display in the View pane: 

 Document - View document control panels in the View pane that enables you to 
view different sections of the document. 

 Tips - Perform tasks, view tips that are Help topics, or view file or folder details, 
such as name, type author and modified date. 

 Folders - View a list of folders in the View pane. 

Note: A search icon is displayed in the View pane of Workspace when you 
select Tools >Search.  

When items have high priority, multiple versions, or is manually flagged as an exception, 
an icon is displayed. In order to see these icons the priority, version, or exception column 
must be displayed. 

Folder Contents: 

 Sub-folders in the left pane; click the plus button next to the folder name. 

 Folders in the left pane and items in the content area; double-click the folder. 

 Contents in the content area; click an item. 

Note: When entering names for items in the repository such as files and 
folders, you can use upper and lowercase letters, spaces and numbers. 
Invalid Name characters are as follows: \,/,%,?,+,<,>,|,`,*,". Invalid Path 
characters are as follows: \,%,?,+,<,>,|,`,*,". 

Viewing Priorities, Exceptions, and Versions 

When an item is listed in Explore, an icon displays indicating priorities, exceptions, or 
multiple versions. You can view and set the following conditions: 

 

 Priority - High or low priority. 

All items that have versions Use version properties to set an item’s priority to Normal or 
High. Only available if your administrator activated the priority feature. 

Note:Priorities for scheduled jobs differ from an item’s priority. Set priorities on 
schedules you associate with jobs. Priority is a property of schedule. If multiple job 
are scheduled to run simultaneously, the high priority job is run first. The priority 
icon is not displayed next to the job.  

 Exceptions - Indicator of conditions or results such as a threshold being reached. 
Notify subscribing users when an exception has been generated and monitor 
exceptions on the Exceptions dashboard on your Personal Pages. 

 Versions - Indicates an item has multiple versions.  
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To display the priority, versions or exceptions column: 

1. View > Show Columns. 

2. Click Priority, Version, or Exception. 

 

 

Managing Files 

This section describes the following tasks associated with managing files and folders in 
the repository. 

 Opening or Selecting Files or Folders 

 Saving Files 

 Creating Folders 

 Moving Files or Folders 

 Renaming Files or Folders 

 Deleting Files or Folders 

 Searching for Files or Folders 

 

Opening or Selecting Files or Folders 

After opening files or folders, it's contents display in the content area. Items have multiple 
versions. Imported files are collections containing a single version. You can later save or 
import additional versions. Versions can be revisions of the same file or completely 
different files. 

Open files using the shortcut menu: 

 From the content area of Explore, right-click a file, from the shortcut menu select 
Open In, then select a format.  

Open files using default formats: 

 From Explore, double-click the file or folder. 

 

Open or select a file or folder: 

1. File > Open > Document. 

2. Navigate to the file or folder, perform the following: 

 From the Name column, double-click the file or folder to open. 

 From Look in, select a folder. 

 To filter the list of items, from the Type list box, click the arrow, 
select the file type. 

 Tip: 
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Click Go Up A Level to move up the folder hierarchy specified in the Look 
in: text box. 

3. Click Open. 

4. Optional: To open a file with another application: 

 Click Options. 

 From Open As: select an application to open the file. 

 Note: 

Every file type on your local system maintains information about which 
application will launch that type of file, and where the application resides.  

5. Optional: To open a version of the item, from Versions list, select the version, click 
Open. 

Saving Files 

Save files to replace them or save files using a new name, which creates a copy of the 
file.  

To save 

1. Open the file.  

2. File > Save. 

3. To save the file with a new name; File > Save As, specify a name and location. 

Creating Folders 

Create folders to organize files and documents. 

To create folders: 

1. Select Navigate > Explore, then select the folder in which you want to create a 
folder. 

2. Select File > New > Folder. 

3. Type a name for the folder, select Save. 

 Note: 

When entering names for items in the repository such as files and folders, 
you can use upper and lowercase letters, spaces and numbers. Invalid 
Name characters are as follows: \,/,%,?,+,<,>,|,`,*,". Invalid Path 
characters are as follows: \,%,?,+,<,>,|,`,*,". 

 

Moving Files or Folders 

You can move a file or folder to another location. 

 Note: 

You cannot make a copy of a file or folder in the repository. An alternative 
solution for copying is to export the file and import it with a new name. 
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To move files or folders: 

1. Select Navigate > Explore, then the file or folder you want to or move. 

2. Edit > Cut. 

3. Click the folder where you want to copy or move the item. 

4. Edit > Paste. 

 Tip: 

To select consecutive files or folders to copy or move, select the first 
item, press and hold down SHIFT, and select the last item. To select files 
or folders that are not consecutive, hold down CTRL, and select each 
item. 

Renaming Files or Folders 

Rename files or folders by changing it's properties. 

Rename files or folders: 

1. Select Navigate > Explore. 

2. Edit > Rename. 

 

 Note: 

When entering names for items in the repository such as files and folders, 
you can use upper and lowercase letters, spaces and numbers. Invalid 
Name characters are as follows: \,/,%,?,+,<,>,|,`,*,". Invalid Path 
characters are as follows: \,%,?,+,<,>,|,`,*,". 

3. Click OK. 

Deleting Files or Folders 

1. Select Navigate > Explore. 

2. Edit > Delete. 

 Caution! 

 Deleted files cannot be restored. 

 Tip: 

 Delete files or folders by right-clicking then Delete. 

Searching for Files or Folders 

Search for files or folders with keywords. Keywords are defined for items in order for the 
search to work.  

Narrow your search by specifying the folder or files location, date, file type, or priority. 
The following rules apply: 

 Not case-sensitive. 

 The search icon displays on the toolbar when you are in Explore only. 
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 The search starts in the folder specified in the Look in: text box and searches all 
sub-folders recursively. 

Search for files or folders: 

1. Select Navigate > Explore. 

2. Select Search from the toolbar. 

3. In Keywords, type a keyword for the file. Wild cards are not supported in the 
Keywords text box. 

 Tip: 

Multiple keywords are separated by a space. A keyword containing a 
space must be double quoted. 

4. For additional search criteria, click Options, specify the following options: 

 Use one method to locate the drive, folder or network you want to search: 

o Look in text box. 

o Select button. 

 Select Types to look for files of a type. 

 Select Date, to look for files from a time period. 

 Specify one of the following search methods: 

o Match on any word (or), to match one word specified in the 
Keywords text box. 

o Match on all words (and), to match words specified in the Keywords 
text box. 

 Select Find Only High Priority to find items marked as high priority. 

 Select Include Hidden Items to search for files that are normally hidden and 
not displayed in Explore. 

5. Click Search Now. 

 

 

Creating E-mail Links to Items 

E-mail links to items in the repository. E-mailing link rules: 

 Recipients must be defined as a user with a Workspace user name and password 
to open the linked item in a Web browser. 

 Recipients need proper access privileges to view the item. 

 Items in the link can be viewed in Web browsers. A link to the item is sent not the 
item. 

When you click on the link, Workspace is opened and the item is displayed. 



Hyperion Workspace  

 
 

 
Page 13 of 52 

 You cannot send an e-mail link to a folder. 

 You must select and send e-mail links one item at a time. 

 You can add text to the e-mail message. 

Create e-mail links: 

1. From the repository, select the item to e-mail. 

 Tip: 

If the e-mail link option does not display for an item, that item cannot be 
sent as an e-mail link. 

2. File > E-mail Link. The Email Link dialog box, containing the URL links is 
displayed. 

 Note: 

If your default e-mail address is not specified, you are prompted to select 
File > Preferences and provide your e-mail address. Your e-mail address 
is used as the sender for the e-mail link. 

3. Perform one of the following tasks: 

 Enter the recipient’s e-mail address. 

 Use the Recipient List, see Using the E-mail Recipient List. 

4. Optional: Update the Subject text associated with the e-mail message. 

5. Click Send. 

 Note: 

 You cannot recall a message after it is sent. 

Using the E-mail Recipient List 

Use the e-mail recipient list to organize a list of recipients to which you send e-mail links. 
By entering addresses in this list you do not need to retype e-mail address again. Two e-
mail recipient lists are maintained; one for e-mailing links, one for e-mailing batch 
notifications. 

Use the e-mail recipient list: 

1. Select File > Email Links. 

2. Click Select to display Email Link, and select recipients. 

3. Optional: To add a recipient, in New Recipient, type the e-mail address and click . 

4. Optional: To remove an e-mail from the selected recipient list, select an e-mail 
and click . 

Using Ambiguous Items 

It is possible for different items to have the same name and reside in the same folder. 
These are ambiguous items. When an ambiguous item is accessed, a list of items with 
the same name are displayed. Select the item you want to use. This may happen when 
you perform the following: 
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 Create e-mail links to an ambiguous item. 

 Prompted to select related content links that link to an ambiguous item. 

Select ambiguous items: 

1. From the list, select the item you want. 

2. To determine the differences between the items, do the following: 

 To view the item properties, right-click the item, select Properties. 

. 

Registering a File Type 

The server maintains information about Repository items and which application to launch 
to open that type of file and where the application resides. 

Administrators create file types (technically, new MIME Types) or add file extensions to 
file types. You may be informed of the new type by your administrator, or you may 
discover it while browsing or trying to open a file. If there is a file type that your browser 
cannot open, you are prompted for a program to open it. To avoid that prompt, you need 
to register the type in your browser or operating system. 

The procedure to register new file extensions or MIME types varies with each operating 
system, its version, your browser, and the browser’s version. Consult the documentation 
or on-line help of the browser or operating system or ask your system administrator. 
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Lesson 3 Review Exercise 

This exercise will review the following lesson objectives: 

1. In the Root directory create the following folder structures 

 Training  

o Admin 

o Publisher 

o Analyst 

o Dynamic Viewer 

o Report Viewer 

o Public 

2. Using the groups created in Lesson 6 of the Shared Services Training assign the 
following permissions to the folders.  

 Training (Administrator, Publisher, Analyst, Dynamic Viewer, Report 
Viewer) 

 Admin – (Administrator) 

 Publisher – (Administrator, Publisher) 

 Analyst – (Administrator, Analyst) 

 Dynamic Viewer – (Administrator, Dynamic Viewer) 

 Report Viewer – (Administrator, Report Viewer) 

 Public  - World 

 

3. Rename the public folder to Training Public 

4. Delete the Training Public folder 
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Lesson 4: Import Artifacts 

Lesson 4 Overview 

Importing artifacts to the repository makes them available to others. You might give 
users the ability to modify one artifact, while limiting others. 

 

Lesson 4 Objectives 

Artifacts are individual application or repository items, such as scripts, forms, rules files, 
Interactive Reporting documents, and financial reports. Artifacts are also known as 
objects. 
 
The primary purpose of this lesson is to examine the procedures for importing artifacts. 
 
At the completion of this lesson, you’ll be able to: 

 Import artifacts 

 Import multiple files 

 Import files as jobs 
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Importing Artifacts 

Import from Explore using File > Import and these instructions: 
 

1. Select Navigate > Explore, navigate to the folder where you want to import the 
artifact. 

2. Select File > Import > File. 
3. Browse to the file you want to import. 

  Required properties are marked with a red asterisk. 
4. Optional: Enter a description, click Next, then click Finish without specifying any 

Advanced options. 
5. Enter properties,  
6. Optional: Click Edit Permissions 
7. Click Finish. 

  Note: 
  To return to a previous pages , click Back from the bottom of the page. 
 

Importing Multiple Files 

 Files must be imported to the current folder. 

 Import different file types together. For example, import text files, HTML files and 
image files. 

 You cannot import multiple Interactive Reporting files (*.bqy, *.oce) or Production 
  Reporting files (*.sqr, *.spf). 
 
To import multiple files: 

1. Select Navigate > Explore, navigate to the folder in which you want the files to 
reside. 

2. Select File > Import > File. 
3. Click Multiple Files. 
4. Select the files you want to import. 

Browse for the first file. click >> (right-facing arrows) to add the file to the list. To 
delete files from the list, select the file and click << (left-facing arrows). 

5. Optional: Enter a description, and click Finish to complete the import without 
specifying any Advanced options. 

6. Click Next. 
7. Enter properties 
8. Click Finish to import the artifact. 

  The artifacts are imported into the current folder. 

 

Importing Files as Jobs 

Import Production Reporting program files (*.sqr) to create Production Reporting jobs, 
Interactive Reporting documents (*.bqy) to create Interactive Reporting jobs or generic 
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files to create generic jobs. Schedule, set options on and execute the job using the 
Schedule module. 
 
To import files as jobs: 

1. Select Navigate > Explore, navigate to the folder where you want to place the 
artifact. 

2. Select File > Import > File as Job. 
3. Browse to the artifact you want to import, and click Next. 
4. Enter properties. 

  Required properties are marked with a red asterisk. 
5. Click Next. 
6. Optional: Click Edit Permissions. 
7. Optional: Define properties for Production Reporting jobs and Generic jobs 
8. Optional:  Define properties for an Interactive Reporting job: 
9. Click Finish. 
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Lesson 4 Review Exercise 

This exercise will review the following lesson objectives: 

1. Create ODBC connection for the North Wind database(SQL Server) 

2. Create DAS connection for North Wind database 

3. Open IR Studio and create OCE for North Wind Database 

4. Save northwind.OCE to open catalog extensions folder. 

5. Save northwind.BQY to desktop 

6. Login to workspace using the admin account 

7. Import the OCE into the Training Folder 

8. Import northwind.BQY into the Training folder and assign to northwind.oce. 

9. Open northwind.bqy using web client.  Create a query, pivot and chart. 

10. Save a copy of the bqy to each folder under Training and assign permissions 
based on group assignments to each folder. 

11. Login using each of the accounts created in Lesson 5 of the Shared Services 
training guide.  

12. Test that the accounts to be sure they can access and perform necessary tasks 
based on user types defined in Lesson 7 of the Shared Services training guide. 

13. Create a Jobs folder in Training(permission all groups with view access) 

14. Create an output folder in Training(permission all groups with view access) 

15. Import into the jobs folder nothwind.bqy you created as a Job. 

16. Create 2 cycles that produce the saved BQY and an excel spreadsheet (pivot). 

17. Save output to output folder. 

18. Permission the job to the Hyperion Admin to run 

19. Permission the output to each group. 

20. Test the user accounts to ensure that they have proper access to Job and output. 
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Review Lesson 4 Objectives 

Congratulations, you’ve completed the lesson that examined the procedures for 
importing artifacts. 
 
You’re now able to perform the following tasks: 

 Import artifacts 

 Import multiple files 

 Import files as jobs 
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Lesson 5: Smart View 

Lesson 5 Objectives 

The primary purpose of this lesson is to Import and Refresh BQY sections into MS Office 
documents. 
 
At the completion of this lesson, you’ll be able to: 

1. Install Smartview 

2. Add, edit and delete a Data Source Connection 

3. Importing Interactive Reporting Documents into Excel, PPT and Word. 

4. Refreshing Interactive Reporting Documents 
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Lesson 5 Overview 

Smart View provides a common Microsoft Office interface for: 

 Hyperion® System™ 9 BI+™ Analytic Services™ 

 Hyperion® System™ 9 Financial Management™ 

 Hyperion® System™ 9 Planning™ 

 Hyperion® System™ 9 Workspace™, which includes the modules: 

o Hyperion® System™ 9 BI+™ Financial Reporting™ 

o Hyperion® System™ 9 BI+™ Interactive Reporting™ 

o Hyperion® System™ 9 BI+™ Production Reporting™ 

o Hyperion® System™ 9 BI+™ Web Analysis™ 

Tasks that previously were repeated across products are now performed only once. The 
single interface also enables users to leverage multiple products simultaneously. Smart 
View replaces the spreadsheet add-in versions prior to Financial Management Release 
4.0 and Planning Release 4.0. Smart View replaces Essbase™ Spreadsheet Services™ 
Release 7.2.1 and earlier versions.  Essbase Spreadsheet Add-in™ for Analytic Services 
continues to be supported with this release. 

Smart View provides tighter Microsoft Office integration by letting you: 

 Import content into Excel, Word, PowerPoint, and Outlook 

 Expose functions for Financial Management and Analytic Services content in 
Word, PowerPoint, and Outlook 

Supported Microsoft Office versions are 2000, 2002, and 2003. 

Using menu-driven options in Microsoft Office, you can import data and images from 
Hyperion products into Microsoft Office. Smart View enables you to take advantage of 
Microsoft Office features, such as smart tags, to add functions and import reports. The 
end user must log in to the data source within Microsoft Office, thus enabling easy 
distribution and sharing of the Microsoft Office document. However, if you log in to a data 
source connection in Microsoft Word, then you must log in again to access data in Excel 
or PowerPoint. 

To view imported data within Microsoft Office, each user in an organization must install 
Smart View. 

 

For the purposes of this training we will focus on using Interactive Reporting with 
smart view. 
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Installing SmartView 

1. From the tools menu select Install>Smart View 

2. Install Smart View to the default path, C:\Hyperion\SmartView, or click Change to 
install the client component to a directory other than the default, and click Next. 

3. Click Install to begin installation of the client files. 

4. Click Finish to exit the installation wizard. 

 

Removing Access to Java Client Installers 

Administrators can hide the Workspace Tools menu option that enables end-users to 
install Interactive Reporting Web Client and Smart View. 

To remove the Tools menu Install option: 

1. Open the \conf\cdsconfig.jsp file that is located in, for example: 

\BIPlus\AppServer\InstalledApps\WebLogic\8.1\Workspace\applications 
Workspace\ 

2. Change the value of the IncludeJavaClientItems parameter to false; for example: 

<module 

…… 

…… 

<param name="IncludeJavaClientItems" value="true" /> 

</module> 

Adding a Data Source Connection 

The data sources to which you can connect are displayed in the Connection Manager. 
You add data sources for Analytic Services, Financial Management, Planning, Financial 
Reporting, Interactive Reporting, Production Reporting, and Web Analysis. You can 
either connect to a data source directly, if you know the URL, or using Shared Services, 
display a list of providers that you can access. 

 

You need to know the following information to add a data source connection: 

 If you are working with a database or repository, the location of the URL where 
the data source is hosted 

 If you are working offline, the path of the local storage directory where your 
metadata resides 

 The user name and password that provides you access to the data source, 
whether it is a URL or directory location 
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Adding a Data Source Through Direct Connection 

When you add a data source connection directly in Connection Manager, you need to 
know the URL for the data source provider to which to connect. A provider can be 
Analytic Services, Financial Management, Planning, Financial Reporting, Interactive 
Reporting, Production Reporting, and Web Analysis data sources. You can get this 
information from your system administrator. 

To add a data source connection through direct connection: 

1. From the Hyperion menu, select Connection Manager. 

2. In the Connection Manager dialog box, click the Add button. 

3. Select URL Provider. 

The Add Data Source dialog box is displayed. 

4. In the Provider drop-down list box, select the type of data source to which you 
want to connect: 

o Hyperion Provider (for Analytic Services, Financial Management, and 
Planning) 

o Hyperion System 9 BI+ Provider (for Financial Reporting, Interactive 
Reporting, Production Reporting, and Web Analysis) 

5. In the Location drop-down list box, type the URL or the local storage directory for 
the data source to which you want to connect, and then click Next. 

The URL syntax for the various data sources is as follows. Contact your 
system administrator for the URL to use: 

Analytic Services: http(s)://<servername>:13080/aps/SmartView 

Financial Management: http(s)://<servername>/hfmofficeprovider/ 

hfmofficeprovider.aspx 

Planning: http(s)://<servername>:8300/HyperionPlanning/SmartView 

Hyperion System 9 BI+Provider:Http(s): 
//<servername>:19000/workspace/browse/ 

listxml 

 

If you are accessing a local storage directory, you can click Browse to open 
the Browse for Folder dialog box. Navigate to the location where your 
metadata resides, and click OK. 

Note: 

You can click the Back button at any time to return to the previous dialog 
box and edit the entries you already made. 

6. Optional: Select the Create as default connection check box to make the data 
source your default connection. 
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7. In the Select Database or Repository dialog box, expand the Servers node. 

A list of servers that are accessible from the URL you selected in step 5 is 
displayed. 

8. Expand the nodes until the object to which you want to connect is displayed, then 
select that object. 

For example, you may want to connect directly to the Analytic Services, Financial 
Management, or Planning application. 

Note: 

You may be prompted to enter your login information if you try to expand an 
application for which you do not have access. 

9. In the Connect to Data Source dialog box, type the user name and password, 
and then click Connect. 

10. Click Next and, in the Add a Connection Name dialog box, type a name for this 
data source connection in the Name text box. 

The data source connection name is also referred to as the friendly name. 

Note: 

Do not use semicolons (;) in connection names planned for using functions. An 
error occurs when using Function Builder to create functions and when pasting 
data points containing functions. 

11. In the Description text box, type any information that is helpful to you in 
identifying this data source, and then click Finish. 

The data source connection you just added is now listed in the Connection 
Manager.  

Adding a Data Source Through Shared Services 

You can connect to any provider that has been registered with Shared Services as a 
provider for Smart View content. Adding data sources through Shared Services 
conveniently provides users with a single location to choose a list of available Smart 
View content providers. 

 

To add a data source through Shared Services: 

1. From the Hyperion menu, select Connection Manager. 

2. In the Connection Manager dialog box, click the Add button. 

3. Select Shared Services Provider. 

The Add Connection From Hyperion Shared Services dialog box is displayed. 

4. In the Hyperion Shared Services URL text box, type the URL to the Shared 
Services server. The URL syntax for Shared Services is as follows: 

http://<sharedservices_server>:58080 

Contact your system administrator to find out the Shared Services server name. 
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5. Click Update. 

A list of available data sources that are registered with Shared Services is 
displayed in the Select a Connection from a Provider list box. 

6. From the Select a Connection from a Provider list box, select the data source to 
which you want to connect. 

7. Click Next. 

8. In the Connection credentials dialog box, type the user name and password that 
you will use to access this data source, and then click Connect. 

9. In the Add a Connection Name dialog box, type a name for this data source 
connection in the Name text box. 

The data source connection name is also referred to as the friendly name. 

10. In the Description text box, type any information that is helpful to you in 
identifying this data source, and then click Finish. 

The data source connection you just added is now listed in the Connection 
Manager.  

Connecting to a Data Source 

You can connect to any data source listed in Connection Manager. Connecting to a data 
source enables you to retrieve data into Excel. 

To connect to a data source: 

1. From the Hyperion menu, select Connection Manager. 

2. In Connection Manager, select the data source to which you want to connect and 
click Connect. 

3. In the Connect to Data Source dialog box, enter the user name and password for 
the data source. 

4. Click Connect. 

5. Click Close to close Connection Manager. 

 

Editing a Data Source Connection 

You can edit existing data sources in Connection Manager. When you edit a data source, 
you can change the provider, change to a different server with the same data source 
provider, or change the application or repository associated with the data source. You 
must disconnect from a data source before you can edit it. 

To edit a data source: 

1. From the Hyperion menu, select Connection Manager. 

2. In the Connection Manager dialog box, select the data source that you want to 
modify and click Edit. 



Hyperion Workspace  

 
 

 
Page 27 of 52 

The Add Data Source dialog box is displayed. 

3. In the Provider drop-down list box, select the type of data source to which you 
want to connect: 

o Hyperion Provider (for Analytic Services, Financial Management, and 
Planning) 

o Hyperion System 9 BI+ Provider (for Financial Reporting, Interactive 
Reporting, Production Reporting, and Web Analysis) 

4. In the Location field, edit the URL of your data source or select from the list of 
available data sources. 

The URL syntax for the various data sources is as follows. Contact the system 
administrator for the URL to use: 

Analytic Services: http(s)://<servername>:13080/aps/SmartView 

Financial Management: http(s)://<servername>/hfmofficeprovider/ 

hfmofficeprovider.aspx 

Planning: http(s)://<servername>:8300/HyperionPlanning/SmartView 

Hyperion System 9 BI+ Provider: 
http(s)://<servername>:19000/workspace/browse/ 

listxml 

5. Optional: Select the Create as default connection check box to make the data 
source your default connection. 

6. Click Next. 

7. In the Select Database or Repository dialog box, expand the Servers node and 
select an application. 

If you do not see any applications, contact your system administrator. You may be 
prompted to enter your login information if you try to expand an application for 
which you do not have access. 

8. In the Connect to Data Source dialog box, enter the user name and password for 
the data source and click Connect. 

9. Click Next. 

10. In the Add a Connection Name dialog box, edit the name and description for your 
connection user name. 

11. Click Finish. 

In the Connection Manager dialog box, the newly edited data source should be 
displayed. 

12. Click Close to close Connection Manager. 

Setting a Default Connection 

The default data source is the data source that is automatically used to retrieve data into 
the Excel worksheet. The default data source will always be the data source used when 
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navigating from worksheet to worksheet. Using Connection Manager, you can choose 
the default connection. In Connection Manager, the data source name listed in bold text 
is the default connection. 

To set the default data source: 

1. In Connection Manager, select an existing data source connection. 

2. Right-click and select Set As Default. 

Deleting a Data Source Connection 

Delete a data source from the list in Connection Manager when the connection is 
obsolete or when you no longer need to connect to a particular data source. You must 
disconnect from a data source before deleting it. 

To delete a data source: 

1. From the Hyperion menu, select Connection Manager. 

2. In the Connection Manager dialog box, select the data source that you want to 
remove and click Delete. 

Note: 

You can delete multiple data sources at once. 

3. When prompted to confirm deletion of the data source, click Yes. 

4. Click Close to close Connection Manager. 

Disconnecting from a Data Source 

Disconnecting from a data source means disconnecting from a live connection to the 
server. The data source connection is still displayed in Connection Manager until you 
delete it. Disconnect from a data source when you do not need to retrieve data from it. 

To disconnect from a data source: 

1. From the Hyperion menu, select Connection Manager. 

2. In the Connection Manager dialog box, select the data source you want to 
disconnect from and click Disconnect. 

Note: 

The Disconnect and Connect buttons toggle, depending on the status of the 
selected data source. 

3. Click Close to close Connection Manager. 

 

Importing Interactive Reporting Documents 

Imported Interactive Reporting documents are section-specific. 
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Section Excel Word, PowerPoint 

Tab le Formatted  Data  NA 

Results Formatted  Data  NA 

Chart Formatted  Data  Image 

Pivot Formatted  Data  NA 

Report Formatted  Data  Image 

Dashboard  Image Image 

Query NA NA 

 

The following restrictions apply when Interactive Reporting documents are imported into 
Excel: 

 Hidden sections are displayed during import. 

 Importing dashboard sections into Excel resizes A1 cells. 

 Importing report sections into Excel places chart images before tables 

 Importing into Excel may not preserve colors correctly. 

 Results sections that contain the euro currency format do not import into Excel. 

 Results sections with "+" in their name do not import. 

 

To import Interactive Reporting documents into Excel: 

1. Using Connection Manager, connect to a Workspace data source. 

2. If you have multiple connections, select Hyperion > Active Connections, and 
select a data source. 

3. Select Hyperion > BI+ Document > Import. 

The Import Workspace Document dialog box is displayed. 

4. In Select a Document, expand the repository, select an Interactive Reporting 
document, and click OK. 

A wizard screen is displayed. 

Note: 

Some wizard screens do not apply to some documents. 

5. In Select an Action, select an option: 

o Process and Preview, to change filters or values prior to previewing the 
document 
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o Preview, to preview the document with default settings 

6. Click Next. 

7. If you selected Process and Preview: 

a. If user authentication is required to change filters, such as variable, value, 
or option in the document's settings, in Specify Database Credentials, enter 
the username and password, and click Next. 

The connection name is displayed in parentheses (for example, Sample.oce). 

b. In Specify Filters, select a value. 

8. Click Apply, and click Next. 

9. If importing a multiple-page document in Preview, use the Page navigation 
buttons to select a page to preview. 

10. Optional: to import all pages of the document, select All Pages. 

11. If your document contains multiple pages, select Split pages across worksheets 
to display each page on a separate Excel worksheet. 

12. Click Finish. 

The document is displayed in Excel. 

 

Importing Interactive Reporting Documents into Word and 

PowerPoint 

To import Interactive Reporting documents into Word: 

1. Using Connection Manager, connect to a Workspace data source. 

2. Select Hyperion > BI+ Document > Import. 

The Import Workspace Document dialog box is displayed. 

3. In Select a Document, expand the repository, select an Interactive Reporting 
document, and click OK. 

Note: 

Some wizard screens do not apply to some documents. 

4. In Select an Action, select an option: 

o Process and Preview, to change filters or values prior to previewing the 
document 

o Preview, to preview the document with default settings 

5. Click Next. 

6. If you selected Process and Preview: 
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a. If user authentication is required to change filters, such as variable, value, 
or option in the document settings, in Specify Database Credentials, enter 
the username and password, and click Next. 

The connection name is displayed in parentheses (for example, Sample.oce). 

b. In Specify Filters, select a value. 

7. Click Apply, and click Next. 

8. If importing a multiple-page document, in Preview, use the Page navigation 
buttons to select a page to preview. 

9. Optional: To import all pages of the document, select All Pages. 

10. Click Finish. 

The document is imported. 

 

Editing Interactive Reporting Documents 

 

To edit Interactive Reporting documents in Excel, Word, and PowerPoint: 

1. Select a page. 

Note: 

When editing a report, select a page from the report, then Edit. If you do not select 
a page, a message is displayed stating that no pages are updated. 

2. Select Hyperion > BI+ Document > Edit. 

3. If you selected Process and Preview: 

a. If user authentication is required to change filters, such as variable, value, 
or option in the document settings, in Specify Database Credentials, enter 
the username and password, and click Next. 

The connection name is displayed in parentheses (for example, Sample.oce). 

b. In Specify Filters, select a value. 

4. Click Apply, and click Next. 

5. If importing a multiple-page document, in Preview, use the Page navigation 
buttons to select a page to preview. 

6. Click Finish. 

 

Refreshing BI+ Documents 

Refreshing updates the report with the latest data from Workspace. If the number of 
pages in a document have changed after the initial import, Refresh or Refresh All are not 
allowed. For example, if the number of pages originally imported is five, but the latest 
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document in Workspace now has three pages, then Refresh or Refresh All does not 
work. To preserve the data integrity of the document, you must re-import the document. 

Refresh behaviors in Production Reporting and Interactive Reporting: 

 In Word, if a report is selected, the entire report is refreshed. If no report is 
selected, the first report found in the document is refreshed. The first report is not 
necessarily the report at the beginning of the document. 

 In PowerPoint, if no report is selected, the first report found in the slide is updated. 

 In Excel, the report in the current sheet is refreshed, even if the report spans 
across worksheets. 

When refreshing job outputs in Production Reporting, new outputs in Workspace 
are updated. 

To refresh BI+ documents in Excel, Word, or PowerPoint, perform an action: 

1. Select Hyperion > Refresh to update the selected BI+ document, including all 
pages associated with that document. 

2. Or, select Hyperion > Refresh All to update all BI+ documents. 
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 Lesson 5 Review Exercise 

This exercise will be written to review the following lesson objectives: 

1. Install SmartView from the tools menu select Install>Smart View 

2. Open Excel and in Hyperion Menu select Connection Manager 

3. Click Add and select Shared Services Provider 

4. Change the Shared Services server name to: http://localhost:58080   

5. Navigate to localhost:1900 and click next 

6. On the next screen click next 

7. In Connection Manager click connect. 

8. Go to Hyperion>BI+ Document>Import 

9. Navigate to the northwind report and select the pivot 

10. Click next in the process and preview window 

11. Click Finish 

12. Close document and save to desktop as sv_excel 

13. Open PPT and go to connection manager In Hyperion Menu. 

14. Connect to BI+ Connection. 

15. Go to Hyperion>BI+ Document>Import 

16. Navigate to the nothwind report and select the chart 

17. Click next in the process and preview window 

18. Click Finish 

19. Go back to the northwind report and add a variable limit. 

20. Go back to PPT and connect. 

21. Go to Hyperion>BI+ Document>edit 

22. Change the limit value and reprocess 
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Review Lesson 5 Objectives 

Congratulations, you’ve completed the lesson that examined the procedures for 
importing and refreshing BQY sections into MS Office documents. 
 
You’re now able to perform the following tasks: 

5. Install Smartview 

6. Add, edit and delete a Data Source Connection 

7. Import Interactive Reporting Documents into Excel, PPT and Word. 

8. Refresh Interactive Reporting Documents 
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Lesson 6: Administration Module 

Lesson 6 Objectives 

The primary purpose of this lesson is to explore and manage items. 

At the completion of this lesson, you’ll be able to: 

1. Change General Properties 

2. Change User and Group BI+ Default Preferences 

3. Manage Physical Resources 

4. Create, Modify, and delete workspace MIME Types 

5. Define end user notifications 

6. Define how SmartCuts are constructed 

7. Manage Row Level Security 

8. Manage Usage and Event Tracking 

 

 

Lesson 6 Overview 

The Administer module, available from the Workspace Navigate menu, enables you to 
manage Workspace properties, performance, and user interaction. Toolbar buttons 
represent Administer menu items: 

General Properties - Define general system and user interface properties 

User Management - Provision users, groups, and roles 

Physical Resources - Specify printers and output directories for job output 

MIME Type - Create, modify, and delete Workspace MIME types 

Notifications - Define mail server properties and how end users receive email 

notifications about jobs 

SmartCuts - Specify how to construct SmartCuts (shortcuts to imported 

documents in Workspace) for inclusion in e-mail notifications 

Row-level Security - Manage row-level security settings in data sources used by 

Interactive Reporting documents 

Usage Tracking - Track system usage and define related properties 

Event Tracking. - Track events, such as document opens, documents closes 

for selected MIME types, and jobs run 
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General Properties 

 System Name—Distinguishes the current installation from other BI+ installations 
(Installation is defined as a system served by one GSM.) 

 Broadcast Messages—Specifies the folder in which to store broadcast messages 

 Enable users to use Subscription and Notification—Activates import event 
logging, which enables Event Service to identify subscription matches and notify 
users of changes in subscribed items (Effective Date—when logging begins) 

 Enable Priority Ratings—Enables users to set priority ratings on items imported to 
the Explore module. 

 Enable Harvesting—Activates Harvester Service, which enables users to use 
Impact Manager to extract and save Interactive Reporting metadata to relational 
data sources for use in other formats. 

User Interface Properties 

 Display all users/groups/roles in the system—Lists all available users, groups, and 
roles when end users set access permissions on repository items. Selecting this 
option may impact system performance. 

 List up to nn users/groups/roles—Number of users, groups, or roles displayed 
when end users set access permissions on repository items; default is 100. 
Specifying too low a number may prevent end users from seeing all users, 
groups, and roles to which they have access. 

 

User Management 

Opens Shared Services Module.  In this module you can: 

Assigning BI+ Default Preferences 

User Management Console enables users with Provisioning Manager and Explorer roles 
to set the default folder, new document folder, and start page application preferences for 
users and groups. Individual and group preferences have precedence over default 
preferences. 

For default preferences to succeed, users and groups must have the roles and 
permissions necessary to access specified folders and interface elements. 

Provisioning Manager is a Shared Services role that enables you to provisions users and 
groups to applications. It is also required for setting default user preferences for BI+.  

 

To assign default preferences for BI+: 

1. Select Navigate > Administer > User Management. 
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2. Log on to User Management Console with a user name provisioned with 
Provisioning Manager and Explorer roles. 

3. Expand the Projects node until a BI+ application is displayed. 

4. Right-click the application name and select Assign Preferences. 

 A three-step wizard is displayed in the Process bar. 

5. For step 1 of the Wizard, Select Users, select Available Users or Available 
Groups. 

6. From the left panel, select user names or group names and click the right arrow. 

To select consecutive names, select the first name, press and hold down Shift, 
and select the last name. To select names that are not consecutive, press and 
hold down Ctrl, and select each item. 

Use Add All to select all names. 

7. Repeat steps 5 and 6 to select a combination of users and groups. 

8. When all user and group names are displayed in Selected Users and Groups, 
click Next. 

9. For step 2 of the Wizard, Manage Preferences, specify these default preferences 
for the selected users and groups: 

o Default Folder—Repository location of the default folder. 

o New Document Folder—Default folder in which the new document wizard 
searches for valid data sources, that is, Web Analysis database connection 
files and Interactive Reporting documents. 

o Start Page—BI+ interface displayed after logging on. Select None, Explore, 
Document, Favorite, Enterprise Metrics, or Scorecard. 

If you select Explore or Document for Start Page, you must specify a 
repository location. 

10. When all preferences are specified, click Next. 

11. For step 3 of the Wizard, Finish, choose between three tasks: 

o To configure options for another application, select one from the View 
pane. 

o To change preferences for currently selected users and groups, click Back. 

o To specify another set of users and groups and set their preferences, click 
Continue. 

Managing Physical Resources 

Physical resources, such as printers and directories, are used as destinations for 
Interactive Reporting and Production Reporting job output. Physical resources must be 
accessible to each server that is running Hyperion Interactive Reporting Service. 

You should assign access permissions and notify end users about which physical 
resources to use. Users should see only the physical resources that they can use. 
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Viewing Physical Resources 

 

To view physical resources defined for Workspace: 

1. Select Navigate > Administer > Physical Resources. 

2. From Display, select All, Only Printer, or Only Output Directory and click Update 
List. 

To view properties settings for physical resources, click a resource name. 

Access Permissions for Physical Resources 

Unlike other BI+ artifacts, which offer several access levels, physical resources have only 
three access levels: No Access, View, and Full Control. 

You add roles, groups, or users and set their access permissions as you do for other 
artifacts.  

 

To add physical resources: 

1. Select Navigate > Administer > Physical Resources. 

2. In the Content pane, click Go next to Add Printer or Add Output Directory. 

3. Specify required properties and optional properties. 

Note: 

Physical resources must be accessible to each server on which Hyperion 
Interactive Reporting Service is running. 

4. Set access Permissions for this resource. 

5. Click Finish. 

To modify physical resources: 

1. Select Navigate > Administer > Physical Resources. 

2. Click Modify next to a resource name or select the resource name. 

3. Make changes and click OK. 

To delete physical resources: 

1. Select Navigate > Administer > Physical Resources. 

2. Click Delete next to a resource name. 

3. Confirm the deletion when prompted. 

Printer Properties 

Printers are used for Interactive Reporting job output: 

 Type—Read-only property; set as Printer 
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 Name—Name for the printer; visible to end users 

 Description—Helps administrators and end users identify the printer 

 Printer Address—Network address of the printer (for example, \\f3prt\techpubs); 
not visible to end users 

Output Directory Properties 

Output directories are used for Interactive Reporting and Production Reporting job 
output. 

They can be located locally or on a network and can be FTP directories: 

 General properties: 

o Type—Read-only property; set as Output Directory. 

 Name—Name for the output directory; visible to end users 

o Description—Helps administrators and end users identify the directory 

o Path—Directory’s full network path (for example, 
\\apollo\Inventory_Reports) 

 FTP properties: 

o Directory is on FTP Server—Enable if the output directory is located on an 
FTP server, and set these options: 

 FTP server address—Address of the FTP server where the output 
directory is located(for example, ftp2.hyperion.com) 

 FTP User Name—User name to access the FTP output directory 

 FTP Password—Password for FTP user name 

 Confirm Password—Retype the password entered for FTP 
password 

Managing MIME Types 

Before you can import items into the repository, their MIME types must be defined in BI+. 

Although BI+ has many built-in MIME types, you may need to define others. 

You can associate a MIME type with multiple file extensions. For example, you can 
associate the extensions .txt, .bat, and .dat with the text MIME type. 

Multiple MIME types can use one extension. For example, if your organization uses 
multiple versions of a program, you can define a MIME type for each version; however, 
file names of all versions use the same extension. When users opens files with 
extensions that belong to multiple MIME types, they are prompted to select a program 
executable. 

In the MIME type list, traffic-light icons indicate active (green) or inactive (red) 

To define MIME types: 

1. Select Navigate > Administer > MIME Types. 

2. At the bottom of the content pane, click Go (to the right of Add MIME Type). 
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3. Supply a name and description. 

4. In the file extensions box, enter an extension and click . 

When entering extensions, type only the extension letters. Do not include a period 
(.). 

5. Optional: Under Advanced Options, click Change Icon, and select from the 
available images or browse to add an image to the repository, then click OK. 

6. Click Finish. 

Note: 

Newly defined MIME types are active by default. 

To modify MIME types: 

1. Select Navigate > Administer > MIME Types. 

2. In the listing of MIME types, click Modify. 

3. Change properties. 

To remove a file extension, select it in the <Extensions> list and click . 

4. Click OK. 

Inactivating or Re-activating MIME Types 

To prevent items from being imported to the repository, inactive their MIME types. 
Although repository items with inactive MIME types are still accessible, end users must 
specify which programs to use when opening them. 

You can re-activate an inactive MIME type at any time. 

To inactivate or re-activate MIME types: 

1. Select Navigate > Administer > MIME Types. 

2. In the MIME type list, click Modify Properties. 

3. Change the Active setting: 

 To inactivate a MIME type, clear Active and click OK. Its traffic-light icon changes 
to red. 

 To re-activate a MIME type, select Active and click OK. Its traffic-light icon 
changes to green. 

 

Deleting MIME Types 

Unlike inactivating MIME types, deletion is permanent and affects associated items. You 
cannot import files that have extensions associated with a deleted MIME type. 

For items associated with a deleted MIME type, the text ―unknown file type‖ is displayed 
instead of MIME type icons. When users open these items, they are prompted to select a 
program executable. 
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You can delete MIME types that you define; however, you cannot delete built-in 
Workspace MIME types. 

To delete MIME types: 

1. Select Navigate > Administer > MIME Types. 

2. Click Delete next to a MIME type. 

Managing Notifications 

Notification properties control how users receive notifications about the jobs and 
documents to which they subscribe. 

Understanding Subscriptions and Notifications 

Subscriptions and notifications are handled by Event Service. 

Topics that discuss how Event Services handles subscriptions and notifications: 

 Subscription Types 

 How Event Service Obtains Information 

 Notification Mechanisms 

Subscription Types 

Subscription types that users can subscribe to and receive notifications about: 

 New or updated versions of items 

 Changed content in folders 

 Job completion 

 Job exceptions 

Independent of subscriptions, Event Service sends notifications to these users: 

 Owners of scheduled jobs, when job execution finishes 

 Users who run background jobs, when job execution finishes 

How Event Service Obtains Information 

When users subscribe to items or folders, Workspace sends subscription information 
through LSM to Event Service, which adds the subscriptions to its subscriptions list. 

Repository Service maintains a list of imported and updated artifacts, which includes all 
imported items, folders, and job output; modified item properties; updated versions; and 
artifact metadata. 

Repository Service includes in its list both imported or modified items or folders, and the 
folders that contain them. 

Every 60 seconds, Event Service obtains the Repository Service’s list of new and 
modified items, and compares them to the subscription list. Event Service then sends 
notifications to subscribed users. 

Repository Service discards its list after giving it to Event Service, which, in turn, discards 
the list after it notifies subscribers of changes. 
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Other services notify Event Service when they complete actions that may trigger 
subscriptions, such as successful job execution. Event Service checks these events 
against the subscription list and sends notifications to subscribers. 

Notification Mechanisms 

Ways in which Event Service notifies users: 

 Send e-mails with embedded SmartCuts to notify users about changes to items, 
folders, new report output, job completion, or exception occurrences 

Optionally, Event Service may send file attachments, based on how users chose 
to be notified on the Subscribe page. 

 Display notifications of completed scheduled jobs or background jobs in the 
Schedule module 

 Display notification of job completion after a job runs in the foreground 

 Display a redlight icon in Exceptions Dashboard when output.properties indicates 
that exceptions occurred 

When exceptions occur, the importer of the file sets properties to indicate the 
presence of exceptions and to specify exception messages. The importer is 
usually Job Service, and the file is usually job output. 

Exceptions can be flagged by any of these methods: 

o Production Reporting code 

o Manually by users who import files or job output 

o APIs that set exception properties on files or output 

 

Hyperion Interactive Reporting Service does not support exceptions, but you can set 

exceptions on Interactive Reporting documents using the API or manual methods. 

Users choose whether to include the Exceptions Dashboard on Personal Pages and 
which jobs to include on the Exceptions Dashboard. 

To modify Notification properties: 

1. Select Navigate > Administer > Notifications. 

2. Modify Notification properties and mail server options: 

Note: 

If you change the ―Enable email attachment,‖ ―Maximum attachment size,‖ ―Mail 
server host name for sending email notifications,‖ or ―Email account name for 
sending e-mail notifications‖ property, you must restart Core services for the 
setting to take effect.  

 Notifications 

o Enable email attachment—Allows end users to send file attachments with 
their e-mail notifications. If jobs generate only one output file, that file is 
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attached to the e-mail. If jobs generate multiple output files including PDF 
files, the PDF files are attached to emails; otherwise, no files are attached. 

o Maximum attachment size—Maximum allowed size for attachments, in 
bytes. 

o Time to live for entries in the notification log—Number of minutes after 
which events are removed from the notification log and are no longer 
displayed in the Explore module. Expiration times for scheduled jobs and 
background jobs. 

 Mail Server Options 

o Mail server host name for sending email notifications 

o Email account name for sending email notifications 

 Note: 

To send e-mails with embedded SmartCuts, you must also set SmartCut 
properties. 

o Require authentication—Makes authentication (ASMTP) mandatory. Enter 
user name and password when enabled. Default is disabled. 

o After specifying notification properties, you can click Send Test E-mail to 
view your mail server entries and enter a destination e-mail address. 

3. Click Save Properties. 

 

Managing SmartCuts 

SmartCuts are shortcuts in URL form to imported documents in Workspace. SmartCut 

properties are used to construct SmartCuts that are included in e-mail notifications. 

URLs for SmartCuts: 

http://hostname:port/workspace/browse/get/Smartcut 

For Example: 

http://pasts402:19000/workspace/browse/get/Patty/ 

Avalanche_CUI_Style_Guidelines.pdf/ 

(Alternatively, a SmartCut may start with https instead of http.) 

To modify SmartCut properties: 

1. Select Navigate > Administer > SmartCuts. 

2. Modify SmartCut properties: 

Note: 

If you change SmartCut properties, you must restart the BI+ server and Job 
Service for the settings to take effect. 

o Name—Web component for the SmartCut 
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o Description—Workspace description 

o Host—Host on which UI Services reside 

o IP Port—Port number on which Workspace runs 

o Root—Web application deployment name for Workspace, as set in your 
Web server software 

Typically, this is workspace/browse. The last segment (browse) must 
match the servlet name specified during installation. 

o Protocol for SmartCuts generated in email notifications—HTTP or HTTPS 

3. Click Save Properties. 

Managing Row-Level Security 

Row-level security enables users to view only those records that match their security 
profile, no matter what their search criteria. It enables administrators to tag data in the 
row level of a database, thus controlling who has read access to information. Row-level 
security is critical to applications that display sensitive data such as employee salaries, 
sales commissions, or customer details. Lack of row-level security could be a big 
detriment to organizations that want to distribute information to their user community 
using the Internet and intranets. 

If you want to implement row-level security in BI+, keep these points in mind: 

  At least one Hyperion Interactive Reporting Data Access Service instance must 
be configured to access the data source storing your row-level security 
information. 

 The database client library should be installed on the computer where the 
Hyperion Interactive Reporting Data Access Service is running. 

 The data source for the BI+ repository that has the row-level security table 
information should be configured. 

 For security reasons, the user name and password to access the data source 
should differ from that used for the BI+ user account. 

Row-level security properties are stored in the repository; however, the rules 
about how to give access to the data are stored in the data source. 

To modify row-level security properties: 

1. Select Navigate > Administer > Row Level Security. 

2. Modify these row-level-security properties: 

o Enable Row Level Security—Row-level security is disabled by default. 

o Connectivity—Database connectivity information for reports’ source data. 

o Database Type—Type of database that you are using. Database types 
available depend on connectivity selection. 

o Data Source Name—Host of the data source database. 
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o User Name—Default database user name used by Job Service for running 
Production Reporting jobs on this database server; used for jobs that were 
imported with no database user name and password specified. 

o Password—Valid password for user name. 

3. Click Save Properties. 

Tracking System Usage 

Usage tracking records information about Workspace activities as they occur and 
provides a historical view of system usage. This information answers questions like: 

 Who logged in yesterday? 

 Which Workspace reports are accessed most frequently? 

You can configure your system to track numerous activities. For example, you can track 
opening, closing, and processing Interactive Reporting documents or you can track only 
opening Interactive Reporting documents. 

Activities are recorded as events in the repository database. Events are recorded with 
pertinent details and information that distinguishes them from each other. Event times 
are stored in GMT. Events are deleted from the database in a configurable time frame. 

Usage Service must be running to track events set in the user interface. Usage Service 
can be replicated and all Usage Services access one database. 

The user name and password to access the usage tracking information may differ from 
that used for Workspace. Hyperion recommends that Usage Tracking use its own 
schema in the repository database; however, an alternate schema is not required. For 
more information about configuring Usage Tracking schema, see the Hyperion System 9 
BI+ Installation Guides. 

Managing Usage Tracking 

Usage tracking is managed through the Administer module and LSC. All configurable 
properties, except run type, are managed in the Administer module.  

To manage usage tracking: 

1. Select Navigate > Administer > Usage Tracking. 

2. Change these properties: 

 General preferences 

o Usage Tracking Active—Select to turn on usage tracking. 

o Mark records ready for deletion after_days—Number of days after which 
usage tracking events should be marked for deletion by the garbage 
collection utility. Default is 30. 

o Delete records every_days—Number of days after which the garbage 
collection utility should be run. Default is 7. 

 Connectivity preferences—User name and password are populated from the 
usage tracking database and should only be changed if the database is moved. 

3. Select Apply. 
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Tracking Events and Documents 

Usage Service keeps records about logon instances, document opens, documents 
closes for select MIME types, jobs run, job output views, and queries processed by BI+. 
Usage Service must be running to track events. By default, events are not tracked. 

To track events: 

1. Select Navigate > Administer > Event Tracking. 

2. Select an event to track it: 

 System Logons 

 Database Logons 

 Timed Query Event 

 Open Interactive Reporting Document 

 Process Interactive Reporting Document 

 Close Interactive Reporting Document 

 Run Interactive Reporting Job 

 View Interactive Reporting Job Output 

 Run Production Reporting Job 

 View Production Reporting Job Output 

 Run Generic Job 

 View Generic Job Output 

3. To track documents, move one or more available MIME types to the Selected 
MIME Types list. 

Tracking occurs each time a document of a selected MIME type is opened. 

4. Click Apply. 

 

Sample Usage Tracking Reports 

Sample usage tracking reports provide immediate access to standard Workspace usage 
reports. You can modify standard reports or create your own reports. The Interactive 
Reporting document, sample_usage_tracking.bqy, which generates usage tracking 
reports, is in the \Root\Administration folder in Explore. 

To view the Administration folder, from Explore, select View > Show Hidden. 
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Review Lesson 6 Objectives 

Congratulations, you’ve completed the production reporting and generic jobs lesson. 

1. Change General Properties 

2. Change User and Group BI+ Default Preferences 

3. Manage Physical Resources 

4. Create, Modify, and delete workspace MIME Types 

5. Define end user notifications 

6. Define how SmartCuts are constructed 

7. Manage Row Level Security 

8. Manage Usage and Event Tracking 
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Review Course Objectives 

 

1. Workspace Overview 

2. Setting preferences and personalizing workspace 

3. Exploring and Managing Items 

4. Importing Artifacts 

5. SmartView 

6. Administration Module 


