Notice: Trying to access array offset on value of type null in /var/www/mediawiki/webroot/mediawiki/includes/profiler/SectionProfiler.php on line 99 Notice: Trying to access array offset on value of type null in /var/www/mediawiki/webroot/mediawiki/includes/profiler/SectionProfiler.php on line 99 Notice: Trying to access array offset on value of type null in /var/www/mediawiki/webroot/mediawiki/includes/profiler/SectionProfiler.php on line 100 Notice: Trying to access array offset on value of type null in /var/www/mediawiki/webroot/mediawiki/includes/profiler/SectionProfiler.php on line 100 Notice: Trying to access array offset on value of type null in /var/www/mediawiki/webroot/mediawiki/includes/profiler/SectionProfiler.php on line 101 Notice: Trying to access array offset on value of type null in /var/www/mediawiki/webroot/mediawiki/includes/profiler/SectionProfiler.php on line 101 Difference between revisions of "Mac OS X Lion" - Library & ITS Wiki

Middlebury

Difference between revisions of "Mac OS X Lion"

Line 1: Line 1:
&nbsp;Mac OS X Lion (10.7.x), released on 22 July 2011, is the newest version of Mac OS X.<br>  
+
&nbsp;Mac OS X Lion (10.7.x), released on 22 July 2011, is the newest version of Mac OS X.<br>
  
 
There are a number of issues related to the upgrade to Lion that involve compatibility of software applications that may not work with the new OS. We are reviewing the situation as it develops but currently we are not distributing OS X Lion (10.7.x) and are recommending that Faculty and Staff refrain from upgrading their College computers.  
 
There are a number of issues related to the upgrade to Lion that involve compatibility of software applications that may not work with the new OS. We are reviewing the situation as it develops but currently we are not distributing OS X Lion (10.7.x) and are recommending that Faculty and Staff refrain from upgrading their College computers.  
Line 5: Line 5:
 
We are testing the upgrade and identifying problem areas, but at this time, support for OS X Lion is minimal.  
 
We are testing the upgrade and identifying problem areas, but at this time, support for OS X Lion is minimal.  
  
We have created a list of customers who have requested upgrade to OS X Lion and will notify them when we are sure that the upgrade will not adversely affect them.<br>  
+
We have created a list of customers who have requested upgrade to OS X Lion and will notify them when we are sure that the upgrade will not adversely affect them.<br>
  
 
Any features discussed here are subject to change. The features and changes discussed here are speculative. For the latest information on Lion, visit:  
 
Any features discussed here are subject to change. The features and changes discussed here are speculative. For the latest information on Lion, visit:  
Line 17: Line 17:
 
*Hardware requirements: Core 2 Duo processor may be required [http://www.macwindows.com/lion-server-beta-released.html#022811a [1]]. This would make us unable to install Lion on some Intel Macs.
 
*Hardware requirements: Core 2 Duo processor may be required [http://www.macwindows.com/lion-server-beta-released.html#022811a [1]]. This would make us unable to install Lion on some Intel Macs.
  
<br>  
+
<br>
  
 
== List of incompatible applications  ==
 
== List of incompatible applications  ==
Line 27: Line 27:
  
 
:*Microsoft Query - little-used Office component that is PowerPC in Office 2011  
 
:*Microsoft Query - little-used Office component that is PowerPC in Office 2011  
:*Communicator - the corporate version of Microsoft’s Messenger chat client (not used at MIDD)<br>  
+
:*Communicator - the corporate version of Microsoft’s Messenger chat client (not used at MIDD)<br>
:*Outlook will not reliably import messages from Mac Mail.<br>
+
:*Outlook will not reliably import messages from [[#mac mail|Mac Mail]].<br>
  
 
*Microsoft Office 2008<br>
 
*Microsoft Office 2008<br>
Line 38: Line 38:
 
== Updates on compatibility - news, updates, upgrades  ==
 
== Updates on compatibility - news, updates, upgrades  ==
  
*Artstor OIV -- v. 3.1.2 is listed as a PowerPC application, but has been confirmed to be running as an Intel application<br>  
+
*Artstor OIV -- v. 3.1.2 is listed as a PowerPC application, but has been confirmed to be running as an Intel application<br>
 
*Symantec AntiVirus for Mac - Symantec Endpoint Protection confirmed to be running as an Intel application<br>
 
*Symantec AntiVirus for Mac - Symantec Endpoint Protection confirmed to be running as an Intel application<br>
 +
 +
[[Mac Mail]] - blah blah
  
 
[[Category:Mac]]
 
[[Category:Mac]]

Revision as of 10:26, 26 July 2011

 Mac OS X Lion (10.7.x), released on 22 July 2011, is the newest version of Mac OS X.

There are a number of issues related to the upgrade to Lion that involve compatibility of software applications that may not work with the new OS. We are reviewing the situation as it develops but currently we are not distributing OS X Lion (10.7.x) and are recommending that Faculty and Staff refrain from upgrading their College computers.

We are testing the upgrade and identifying problem areas, but at this time, support for OS X Lion is minimal.

We have created a list of customers who have requested upgrade to OS X Lion and will notify them when we are sure that the upgrade will not adversely affect them.

Any features discussed here are subject to change. The features and changes discussed here are speculative. For the latest information on Lion, visit:

http://www.apple.com/macosx/lion/

New features and changes

  • There is now only one product: Mac OS X Lion for both clients and servers (Mac OS X server is no more).
  • Java is not available in Mac OS X Lion out of the box (at least in developer releases). This means that running the first Java application on Mac OS X Lion will prompt the user to download the Java installer from Apple. We will likely fix this on our Middlebury image.
  • Hardware requirements: Core 2 Duo processor may be required [1]. This would make us unable to install Lion on some Intel Macs.


List of incompatible applications

Support for PowerPC applications has been dropped. In theory this would make the following applications incompatible unless the vendor releases a new version

  • In general, any application written for PowerPC processors is not compatable.
  • Microsoft Office 2011
  • Microsoft Query - little-used Office component that is PowerPC in Office 2011
  • Communicator - the corporate version of Microsoft’s Messenger chat client (not used at MIDD)
  • Outlook will not reliably import messages from Mac Mail.
  • Microsoft Office 2008
  • Entourage will not reliably import messages from Mac Mail.
  • Microsoft Office 2004 is not compatable.

Updates on compatibility - news, updates, upgrades

  • Artstor OIV -- v. 3.1.2 is listed as a PowerPC application, but has been confirmed to be running as an Intel application
  • Symantec AntiVirus for Mac - Symantec Endpoint Protection confirmed to be running as an Intel application

Mac Mail - blah blah