Middlebury

Difference between revisions of "Template:Hi"

Line 3: Line 3:
 
* Add a link to a page in the hi (Helpdesk Internal) wiki:
 
* Add a link to a page in the hi (Helpdesk Internal) wiki:
 
** <code>
 
** <code>
 +
  
 
<nowiki>{{hi|ArticleName}}</nowiki> </code> &raquo; {{hi|ArticleName}}
 
<nowiki>{{hi|ArticleName}}</nowiki> </code> &raquo; {{hi|ArticleName}}
 
* You can also include optional text:  
 
* You can also include optional text:  
 
** <code>
 
** <code>
 +
  
 
<nowiki>{{hi|ArticleName|some other text to display}}</nowiki> </code> &raquo; {{hi|ArticleName|some other text to display}}
 
<nowiki>{{hi|ArticleName|some other text to display}}</nowiki> </code> &raquo; {{hi|ArticleName|some other text to display}}
  
Warning: This template seems to have a bug where if this HI template link is inserted into a paragraph and there is a '''space''' directly after it, the rest of that paragraph will be shoved into a lower dotted line like this: (If you go to Edit, you'll see that the following blah blah blah section should all be on the same line!)
+
Warning: You must use underscores in article names. Example "Main_Page" rather than "Main Page".  
 
 
Paragraph blah blah blah {{hi|Main Page|HI Main Page}} blah blah blah end of paragraph.
 
  
Unfortunately, the only workaround I know of so far is to format sentences so that any HI links go at the end of the sentence, with a period directly after them, so that this problem is avoided.
+
I'm not sure what changed, but the space-after-template bug seems to be gone now. -- [[User:Afranco|Franco, Adam]] 17:25, 16 December 2008 (UTC)
  
 
</noinclude>
 
</noinclude>

Revision as of 12:25, 16 December 2008

Usage

  • Add a link to a page in the hi (Helpdesk Internal) wiki:


{{hi|ArticleName}}
» ArticleName

  • You can also include optional text:


{{hi|ArticleName|some other text to display}}
» some other text to display

Warning: You must use underscores in article names. Example "Main_Page" rather than "Main Page".

I'm not sure what changed, but the space-after-template bug seems to be gone now. -- Franco, Adam 17:25, 16 December 2008 (UTC)