Middlebury

Backing Up Your Data

(Redirected from Selective Backup)

Related topic: Setting Up Your College-Owned Computer (go/setup/)

The purpose of this page is to instruct you on how to back up your important computer files and make you aware of settings and customizations that you may need to consider so they can be replicated on a new or re-imaged computer. Work-related data should be backed up to an appropriate location on OneDrive, GoogleDrive, or a shared departmental folder on Middfiles (ORGS).

  • Visit go/cloudoverview for information about Middlebury-managed cloud storage.
  • Visit go/fileserverinfo/ for information about Middfiles structure and use.
  • If you have non-work-related personal data (videos, music, pictures, etc.) that also needs to be backed up, you must use your own storage, such as cloud storage, an external hard drive, CD, DVD, or USB device.


Please note that if we are re-imaging your computer to resolve a problem, this process will remove all data from it, so it is critical that you make sure all of your data is backed up ahead of time.

General Preparation Tips for an Upgrade or Re-image

If you are about to receive a computer upgrade or have your existing computer re-imaged to address a problem, these tried and true tidbits can make the process go smoothly.

  • Create a new folder on OneDrive or Google Drive to hold your upgrade-related (or re-image-related) items, such as screen snapshots, favorites, signatures, bookmarks, etc., so you can easily find them.
  • Try using a different computer for a day -- or even half a day. What's missing? It may be software you'll need to request or files that are stored on your hard drive that need to be copied to OneDrive, Google Drive, a shared dept folder Middfiles, or a personally-owned storage device to avoid being lost.
  • Take screen snapshots to help you remember how things look (such as Outlook's navigation pane, customizations, your desktop, the Taskbar or Dock). You can gather these in a Word document for future reference. Here's how:
  1. Launch Word.
  2. Insert screen snapshots by clicking the Insert tab, then clicking the Screenshot button. You can insert the image of any of the displayed active windows -- or you can choose Screen clipping to select just a part of the first window shown.
  3. Right-click in your Word document, then choose Paste.
  • And lastly... take advantage of this chance to do some housecleaning!


PC (Windows)

This section contains tips and instructions on how to back up files and settings on Windows computers.

Your Special Software Needs

Before ITS begins preparations for a computer upgrade or re-image, they will ask you to provide a list of all special software you use that will need to be installed. The following software is automatically installed : MS Office suite (Outlook, Word, Excel, and Powerpoint), Internet Explorer 11 and Firefox browsers, and Adobe PDF reader.

To refresh your memory about other software you should request to have installed:

  • Review the program icons on your Taskbar and Desktop.
  • Click the Start button (Windows orb), click All Programs, then review the program entries and folders.


Locally-Stored Files

"Local" files are ones that are stored on your computer's hard drive (as opposed to in the cloud). If copies of such files are not saved elsewhere then they will not be available on your new or re-imaged computer.

If you have documents covering your desktop, or use folders such as "My Documents," "My Pictures," and "My Music", then you have items that will be lost if you do not take appropriate steps!

  1. Open Windows Explorer by clicking the icon on the Task Bar.
  2. Navigate to C:\Users\username.
  3. You'll find a variety of local folders which often contain important items -- review the contents of these in particular, watching for .docx, .xlsx, .pptx, etc.:
    • Desktop (the folder that holds everything you have on your computer's desktop!)
    • My Documents, My Music, My Pictures, and My Videos (where most people find items they need to copy elsewhere, such as the iTunes Library folder)
    • Downloads (check here in case you need to save any recently downloaded files)
  4. Now you can drag and drop any work-related files from these local folders to OneDrive or Google.
    • Refer to OneDrive use (or "Google Drive use") for detailed instructions.
    • Any media files, such as pictures and videos, may also be stored in your Middlebury OneDrive or Google Drive folder if they are work-related, otherwise please copy them to a personally-owned external storage device.


Browser Favorites (Bookmarks)

Many web browsers now support syncing of bookmarks and other settings so you don't have to locate and copy them yourself. Once you create an account you can use it to log in on other devices; your bookmarks and settings will be brought in for you automatically! See appropriate links below to learn how to take advantage of this handy feature.


Web browsers also support saving bookmarks and settings to a file that can be used on different devices or browsers. This process is known as exporting and importing.


Note Printers You Currently Use

You'll want to jot down the names of the printers that are currently installed on your computer. Here's how to find the details:

  1. Click the Start button (Windows orb), then click Devices and Printers.
  2. Write down the printer names -- or take a screen snapshot -- so you'll know which ones to re-install on your new or re-imaged computer.


Outlook Points to Consider

Additional Mailboxes

Do you have access to other email accounts in addition to your own? Scroll through the navigation pane at left and note the names of all other such accounts. Quite often these will reconnect automatically when you access Outlook on a new or re-imaged computer, but it's best to know what should appear in case some do not.

Archived Email

Outlook contains a feature called AutoArchive which saves all e-mail older than 6 months to a file on your local hard drive and deletes it from our email servers. We do not typically recommend using AutoArchive, but we occasionally find it in use -- often by accident -- so it's good to take a look:

  1. Go to your Outlook folder in Windows Explorer (C:\Users\username\Documents\Outlook Files) and highlight all files ending in ".pst".
  2. Make sure in particular your selection includes "outlook.pst" and "archive.pst".
  3. If you have Windows Explorer configured not to show file extensions for known formats, look for Microsoft Office Outlook Personal Folders files.
  4. Select Edit | Copy from the menu to copy the selected files.
  5. Open the folder where you want to put your backup copies in Windows Explorer (your OneDrive or Home drive (U:) on Middfiles could be used).
  6. Select Edit | Paste from the menu to paste your .pst files to the backup location.
  7. In the Folder List of Outlook, look to see if you have Personal File Folders or Archive Folders  -- these are stored on the local computer itself, not on the e-mail server. You can use Control Panel => Mail => Data Files to open the folder where the .pst files are stored, then back them up.


Signatures

If you only use one or two Outlook signatures, it's often quicker just to recreate them by copying from an old message once you have your new or re-imaged computer.

If you use multiple signatures, you'll want to save the files for later use. Here's how:

  1. Launch Outlook, then click File / Options, then Mail.
  2. Hold down the CTRL key when you click the Signatures button. This opens the hidden folder where the signatures files are stored.
  3. Use CTRL+A to select them all.
  4. Right-click any selected file, then choose Copy.
  5. Navigate to a storage location (OneDrive or Google Drive) then create a new folder where you can store the signatures for later use.
  6. Open your new folder, right-click in the right-hand pane, then choose Paste. Your signature files are now stored for later use.
  7. Close the Signatures window, then click OK.



Favored Views

If you have made numerous adjustments to the pieces of information Outlook displays and how it looks, you might benefit from saving your view with a name. Named views can be re-applied easily and are stored on the email server.

To save a view:

  1. Click Outlook's View tab.
  2. Click the Change View button; you'll see Outlook's preset views as well as any you have created.
  3. If needed, click Save Current View as a New View.
  4. Supply a name for your new view, then select All Mail and Post folders to make it available for use in any Outlook folder.



Other Customizations to Consider

  • Office Templates
  • Quick Access Toolbars
  • Ribbons



iTunes


Apple support information: How to move your iTunes library to a new computer


The following information applies only if your computer is being replaced.

If you are an Apple iTunes user and store music, photos, etc. on your computer, it is very important that you Deauthorize your old computer before ITS replaces it. This process allows you to release your personal iTunes account (with attached device ID) so it can be applied on a new computer.



Apple (Mac)

This section contains tips and instructions on how to back up files and settings on Apple (Mac) computers.

Your Special Software Needs

Before ITS begins preparations for a computer upgrade or re-image, they will ask you to provide a list of all special software you use that will need to be installed. The following software is automatically installed : MS Office suite (Outlook, Word, Excel, and Powerpoint), Safari and Firefox browsers, and Preview (for viewing PDFs).

To refresh your memory about other software you should request to have installed:

  • Review the program icons on your Dock and Desktop.
  • Open the Applications folder (Go > Applications), then review the program folders within.


Documents


On an Apple computer running 10.x or higher you will want to copy the following container to your external source:

Open Finder, select "Macintosh HD", then select "Users", then highlight your <username> and copy the entire contents inside this folder to your external storage destination.

NOTE: "Users" contains most things you will care about when wanting to restore data to your new computer: your Word, Excel, PowerPoint, iWork, PDFs, pictures, music, movies, and more are stored inside this container. Be warned that if you have excessive files (especially personal files not related to your work) you may need to use a personal external storage drive.

Work-related files should be copied to your Middlebury College OneDrive or Google cloud storage. Refer to the appropriate resource:


Non-work-related files must be backed up to an external drive, as the College's cloud storage accounts are for work-related use only.

Outlook Points to Consider

Additional Mailboxes

Do you have access to other Middlebury accounts in addition to your own, such as a shared fax mailbox or other shared email accounts for office/department use? Scroll through the navigation pane at left and note the names of all other such accounts. These accounts will not appear automatically on a new or re-imaged computer so you'll need these names in order to re-add them.

iPhoto, iMovie, FinalCut, iDVD, and other picture and movie files

These need to be backed up to a CD, DVD or external hard disk (the FireWire drives from the Library are not meant for backups).

Backing up iPhoto to an external hard disk

  1. Click on your Desktop
  2. Click "Go" on the top of the screen and select "Home"
  3. Drag the Pictures folder to the external hard drive (this will copy, and not move the Pictures folder, including the iPhoto library)

Browser Favorites (Bookmarks)

Many web browsers now support syncing of bookmarks and other settings so you don't have to locate and copy them yourself. Once you create an account you can use it to log in on other devices; your bookmarks and settings will be brought in for you automatically! See appropriate links below to learn how to take advantage of this handy feature.

Safari bookmarks are all stored in a file called Bookmarks.plist, which is located at ~/Library/Safari/. To get to this file in the Finder, hold down the Option key then choose Library from the Go menu. Open the Safari folder.
To back up: Make a copy of the file in another location by holding down the Option key and dragging the Bookmarks.plist file to another location (such as the Desktop). The original file will remain (do not remove the original file from this location or your Safari bookmarks will be gone!).
As an alternative, you can compress the file into an archive—select the Bookmarks.plist file, then from the File menu in the Finder, choose Create Archive. The original file will remain.
To restore: Simply move the backup copy of Bookmarks.plist to the ~/Library/Safari/ folder. If you're restoring from an archive, don't forget to decompress the file (just double-click it).
Note: The Bookmarks.plist file contains only the Safari bookmarks for the currently logged-in user. If other users on the same Mac have their own user accounts and personal bookmarks, their Bookmarks.plist files are located in their Home folders.

iTunes


Apple support information: How to move your iTunes library to a new computer

This is only applicable if your computer is being replaced
If you are an Apple iTunes user and store music, photos, etc... on your computer that will soon be replaced by ITS it is very important that you "Deauthorize" your old computer before replacement. This process allows you to release your personal iTunes account (with attached device ID) to apply on a new computer. To "Deauthorize" your iTunes account you will need to follow the instructions here: http://support.apple.com/kb/ht1420

Powered by MediaWiki